Versions 3, 4, 5 Discontinued

As of July 31st, Waves will discontinue product support for versions 3, 4, and 5 (as well as GTR Solo Versions 6, 7 and 8).

Although these versions have not been “officially” supported for quite some time, we have continued to provide downgrade options, compatibility information, tech support and so on, but after so many years it is no longer possible to support outdated and/or discontinued operating systems, DAWs, plugin formats and the like.

These installers will remain on our website for download until the end of the month, and your version 3/4/5 product will continue to work on your current system as is, however any further support will no longer be available after July 31st.

You may update your product to the latest version (V9) at any time by renewing your Waves Update Plan, or upgrading to a bigger bundle (and receive V9 at no additional charge.) Over the years, we have added new plugins to many bundles, and with Waves V9, it’s easier than ever to manage your plugin licenses.

Once your Waves Update Plan is current, an Update link will appear next to your product.

See Specials

Recent Videos

Recent Posts

Categories: News

Tags: Support