Ends Tomorrow: All CLA Plugins $29.99 | Shop Now »

System Requirements

Jun 21, 2023

This page will help you determine if your system specifications meet the requirements to run various versions of Waves Plugins, Waves Central, and Waves applications including eMotion LV1, SuperRack, SuperRack Performer, SoundGrid Driver, SoundGrid Rack for VENUE, SoundGrid Studio, StudioRack and Tracks Live.