How to Run Waves Plugins on Logic 9

Last updated on: 2/8/2016 9:33:14 AM

To run Waves plugins on Logic 9, you must use a Waves V9.3 offline installer, which only includes Waves products released until September 10, 2015.

Logic Pro 9 is not officially supported by Waves 9.3 and up. For a comprehensive list of officially supported DAW hosts and their versions, please see our Supported Hosts page. If you can update to a supported version of Logic (or use any other supported DAW), please do so. If this is not an option, follow these instructions.

If you are using OS X 10.7 to 10.7.5, please refer to this article. If you are using OS X 10.8.5 or later, proceed to the following instructions:

  1. Remove current version of the plugins:
    (a) Launch Waves Central.
    (b) Choose Install from the top menu, and select the Uninstall option.
    (c) Check All Waves Plugins and click the Uninstall button.
  2. Install Waves plugins V9.3:
    (a) Quit Logic.
    (b) Download and run the Waves V9.3 Installer for Mac.
    (c) In the Installation Type menu, check the plugins or bundles for which you have licenses, and complete the installation process. Note that non-bundled plugins are listed under the Single Plugins category.

Your plugins are now installed and should be available for you in Logic.

Please note that products released after September 10, 2015 will not be added to the v9.3 installer. Check our Release Notes for specific information.


To manage your licenses after the plugins have been installed, use the Manage Licenses section of the Waves Central application.

Was this article helpful?