Sale Extended | Limited Time
CYBER MONDAY SALE: Plugins starting at $599
Sale Extended | Limited Time
CYBER MONDAY SALE: Plugins starting at $599
| Shop Now

Incompatible Device in SoundGrid Inventory

Last updated on: 10/20/2021 5:21:58 AM

All SoundGrid Interface drivers are now pre-installed with each SoundGrid application. If you see this message, reinstall your SoundGrid application or the specific device driver via Waves Central's 'All Products' tab.

If you encounter this message running a V9 SoundGrid Application (MultiRack, SoundGrid Studio V9 or eMotion LV1 V9), please follow the instructions in this article to re-install the SoundGrid Interface driver/s.

Was this article helpful?