48HRS ONLY: Reverb & Delay plugins $29.99 each | Shop Now

How to Roll Back from Waves V12.7 to V12.0

Last updated on: 2/23/2021 7:24:03 AM

If your system or host application does not support Waves V12.7 software and you have inadvertently updated, follow these steps to roll back to V12.0.

First, please refer to our System Requirements and Supported Hosts pages to determine the software version best suited for your setup.

Important Notes:
  • V12 licenses will activate V12.7 and V12.0 software, as well as earlier V9-V11 software versions, if the product in question exists in any of those versions.
  • To check if a plugin exists in an older version, scroll to the bottom of the version’s download page.

How to roll back:

First, uninstall the V12.7 plugins:

  1. Quit any host application.
  2. Launch Waves Central.
  3. In the left-hand side, click on the Settings page.
Under Maintenance, click on the Uninstall drop-down menu and choose to uninstall V12.7 Plugins.

Once uninstalled, install V12 plugins, using an offline installer (V12.0 is no longer available for online installation via Waves Central)

  1. Quit any host application.
  2. Download the V12.0 Offline Installer for | .
  3. Unzip the folder to your desktop.
  4. If you have the current version of Waves Central:
    • Launch the Waves Central application on the system where your licenses are activated:
      Windows: via the desktop shortcut or Start Menu > All Programs > Waves Central.
      Mac:Applications > Waves Central.
    • Log into Waves Central.
    • Access the Offline Installer Page. Under Install from an Offline Installer, click Browse.
    • Browse to your Desktop > Waves V12.0 - 17.2.21 and click Open.
    • Select the products you wish to install from the list.
    • Click Install.
  5. Important Notes:
    • After this installation is completed, each launch of Waves Central will display the Updates Available notice on the top right corner.
    • Do not install these updates, as this will update the software back to V12.7 which is not compatible with your setup.

The offline installer includes:

Last updated: February 17th 2021

  • All Waves plugins v12.0 (see below full list)
  • SoundGrid Studio v12.4.0.174
  • SoundGrid Driver (ASIO/Core Audio) v12.2.0.130
  • StudioRack v12.4.0.161
  • SuperRack v12.2.0.180
  • eMotion LV1 v12.3.0.155
  • SoundGrid QRec v12.2.0.155
  • SoundGrid Server v12.2.0.112
  • Drivers v12.x for SoundGrid Audio Interfaces
  • MyMon v11.3961

This installer does not include sample libraries, which can be downloaded here.

None of the above worked? Contact Waves Technical Support.

Was this article helpful?