Browsing Error Using Safari 6.2.8 or Earlier

Last updated on: 12/3/2015 11:04:41 AM

Safari version 6.2.8 or earlier are not secure and can therefore not be used to enter the secure (https) areas of our website: store checkout and client accounts. To access these areas, please update your Safari to version 6.2.8 or higher, or use other browsers such as Chrome or Firefox.

Tags: Website

Was this article helpful?