Avid VENUE Systems V3 – V3.1.1 Compatible Plugins

Last updated on: 11/25/2019 10:07:02 AM

While Waves products v9.6 or later no longer support the TDM format, there are a number of Waves plugins which can be used on legacy VENUE systems, listed below.

For downloads, installation & activation instructions, see here.

Compatible Plugins

* Requires a full SSL 4000 Collection license for activation. Single plugin licenses will not activate these plugins on Venue V3 setup.

Compatible Bundles

Tags: Tech Specs

Was this article helpful?