Mac OS X 10.10 Yosemite Compatibility

We are pleased to announce that all Waves Native plugins V9 as well as the Waves License Center are now fully compatible with Mac OS X 10.10 Yosemite.

download now

If further assistance is required, you are more than welcome to contact our tech support team.

See Specials

Recent Videos

Recent Posts

Categories: News

Tags: Support