iLok Authorization Not Available

Downgrades from Waves V9 to earlier versions and iLok authorization are no longer available for Waves products.

If you have a lost/defective iLok key, you can update to Version 9 free under the Waves Update Plan.

An iLok RMA is no longer necessary at this time for these situations.

Please take a moment to read more about Waves V9.

If you need any assistance or just want to ask a question, our stellar Tech Support and Sales teams are just one click away.

See Specials

Recent Videos

Recent Posts

Categories: News

Tags: Support