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1. What Do I Need


Waves I/O card: Pre-installed in the console



Waves-qualified SoundGrid DSP Server: A multi-core PC used for real-time
audio processing. See a list of Waves-qualified servers at:
http://www.waves.com/live-sound/soundgrid-servers A second server may be
added to your system for Redundancy.



Network switch: See a list of Waves-certified switches at
http://www.waves.com/live-sound/soundgrid-switches



Ethernet Cables: Standard CAT5e or CAT6 Ethernet cables. See a list of
supported length per cable type and application
http://www.waves.com/1lib/pdf/live/soundgrid-cables.pdf



USB flash drive with activated SoundGrid-compatible V9 licenses: The USB
flash drive holds the licenses for the Waves plug-ins. To verify USB flash drive
compatibility: http://www.waves.com/support/usb-flash-drive-formats



To learn more about Waves License Center:
http://www.waves.com/support/waves-license-center



For activation instructions: http://www.waves.com/support/activate - Choose the
“My audio computer is NOT online” tab.



MultiRack SoundGrid V9 for DiGiCo: No license is required.

See a list of SoundGrid-compatible plug-ins at http://www.waves.com/live-sound/soundgridplug-ins

Please note:
•

Only SD consoles running V443 or higher are able to run Waves V9.

•

For instructions on how to upgrade your SD Series console to V442+, please refer to the
relevant DiGiCo Tech Note for your console.
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2. Connecting Your Console to the SoundGrid Network

First, shut down your console.


If you are in the SD application, Quit to Windows.



On SD7, use the System>Quit to Windows button.



On all other SD Consoles, press Alt-F4 in the mixer program

Connect the Waves SoundGrid card Ethernet port to a network switch.

SD7: Connect both Waves SoundGrid card Ethernet ports (both engines) to a network switch.



Connect the console’s Ethernet port to the network switch with another network cable
SD7: connect both console Ethernet ports (both engines) to a network switch.



Connect the SoundGrid DSP Server Ethernet port to the network switch using an
Ethernet network cable. For server redundancy or to comply with SD7 redundancy
scheme, connect the second SoundGrid DSP Server’s Ethernet port to the network
switch.



Connect a USB flash drive with activated V9 plug-in licenses to the console’s USB port.
SD7: On B engine, connect another USB flash drive with an identical set of activated V9
plug-in licenses.
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Disconnect All Optocore, MADI, Local I/O Audio, CAT5, iLok and headphone connections
before proceeding with this upgrade.



Reboot the DSP Server, network switch and the console.
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3. Disabling ReadyOn

Your SD Console OS is protected by ReadyOn. Unless ReadyOn is disabled, any changes
made to the OS, including network and display settings, will be lost when the SD console is
switched off.

Important: Connect a secondary screen to the console during this procedure, or it may
become disabled after ReadyOn is re-enabled. (Does not apply to SD7.)


Right-Click on the Start Menu, and choose “Explore”.



Navigate to C:\Program Files\Ardence\ReadyOn, and then run ReadyOn.exe



The following window will open:



Click Flush, as indicated above. The following progress bar will appear:



Ready ON is now disabled.
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4. Extracting to USB Flash Drive

First, login to your Waves account and download All-In-One Waves V9.5 for DiGiCo installer
from http://www.waves.com/downloads/digico .
Windows
Available space required on USB flash drive: 2GB


Run the installer. Choose your USB flash drive root folder as your destination and click
Extract. Please note: This process will take about 6-8 minutes



Plug the USB flash drive into a USB port on your DiGiCo SD console.



Right-click on the Start Menu button on the Windows toolbar, and choose Explore.



Continue to Installation (below)
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5. Installation from USB Flash Drive

1. Navigate to your USB flash drive and run the Install Waves for DiGiCo.bat installer
from your USB flash drive. It will install the following items:
o

MultiRack SoundGrid V9 for DiGiCo

o

All MultiRack SoundGrid-compatible plug-ins

2. Once installation complete, you will be prompted to restart your computer.
3. Once restarted, the console will boot to Windows, without loading the SD software.
When installing on a clean system follow the steps 4-9, otherwise continue to chapter 6.
4. Insert your USB flash drive into the USB ports on the control surface.
5. Windows New Hardware Wizard will appear on Screen.
6. Select Install Software Automatically and click Next
7. Once this process is complete, click Finish
8. Repeat Step 4 – 7 for each of the USB ports on your console. (SD7 has a single
USB connection only.)
9. Remove all USB flash drives from the console.

6. Enabling ReadyOn

SD7 users: Before enabling ReadyOn on your first engine, ensure that both engines are
connected via Ethernet and that the second engine is active and running the Windows desktop.

1. Remove all USB flash drives from the console.
2. Right-click on the Start Menu, and choose Explore.
3. Navigate to C:\Program Files\Ardence\ReadyOn, and run ReadyOn.exe
4. Close all open windows except the ReadyOn window.
5. Press Flush.
6. In the Command or Application to run at ReadyOn Boot box, type the following path:
D:\SDxx\SDxx.exe (xx is the number of the SD console you are using (e.g.,
D:\SD7\SD7.exe)
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7. Press Image; the System Hibernating message should appear.
o

Please note: If you receive an error message after pressing Image, OK the error,
close the ReadyOn program and restart the console using the Windows Start
Menu. The console will restart and boot to Windows. Then repeat the process as
described above.

o

SD7 users: Once the first engine has Hibernated, turn off the console using the
Main Power Switch. Reboot the engine and wait for it to load the SD application
again before enabling ReadyOn on the second engine.

8. Turn off the console using the Main Power Switch, then turn it on again.
9. Connect your USB flash drive containing your Waves licenses.
10. The software upgrade process is now complete.
o

If you are upgrading an SD7, please repeat this process for your second engine.
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7. Enabling Waves MultiRack Tab

If no Waves button appears on the Master Screen, then Waves has not yet been enabled.
Click Options > Console as indicated below, and set Enable Waves MultiRack to Yes.

Now, restart the console. The Waves button will now appear on the Menu bar; the Options
button will now appear under Setup.
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8. Connecting Waves Port I/O



On the Menu bar, touch Setup > Audio I/O.



Check the Ports column on the left; if you don’t see Waves, touch Add Port and add
Waves.



Touch the Waves Port; you will see two added columns of 16 inputs and outputs;
(32 inputs and outputs on the SD7).
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9. Selecting Host Network Interface

On the Menu bar, touch Waves to open the MultiRack SoundGrid interface and select
Preferences from the Window menu. Set your system by selecting the Host Network Interface
on your host computer.

Local LAN Port lists the available network adapters on the host machine. Choose the network
adapter that is connected to the SoundGrid network. Network adapters are displayed by MAC
addresses and port name. When you select the proper port, SoundGrid Network Found will
appear.
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10.

Selecting Plug-in Version

Plug-in Manager Tab: Touch the Waves top row button to open the MultiRack SoundGrid
interface, and select Preferences from the Window menu. Touch the Plug-in Manager Tab
and make sure Plug-ins V9 is checked.

11.

Setting SoundGrid Inventory
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This window is accessed by selecting the SoundGrid Inventory from the Window menu.

Changes in the Inventory window are allowed only in Setup mode. In Show mode, the window
opens as display-only and no changes are allowed. Changes made in the Inventory window are
applied immediately.

System Parameters
Sample Rate displays sample rate. MultiRack SoundGrid is slaved to the console’s sample
rate; this field cannot be edited.
Network Latency sets the network latency value. This field allows you to change SoundGrid
network throughput latency. This value sets the buffering delay used by the processing
engine(s) and affects SoundGrid’s end-to-end latency. Plug-ins that add latency will add to the
overall latency (system latency + plug-in latency) of the specific Rack into which these plug-ins
are inserted. See http://www.waves.com/live-sound/soundgrid-servers for correct settings
Test Redundancy. A setup is redundant once you have designated a second Server as a Test
Redundancy: In a setup using a Redundant Server, a second server is connected to the main
audio processing DSP server. If the main server fails, then the secondary backup server
automatically takes over and begins processing. Click the Test Redundancy button to make
sure the Redundant Server is capable of holding the session being handled by the main server.
This is important when the two servers are not identical.
Refresh is used to refresh the inventory list after you have changed devices or settings. The
Inventory table displays all SoundGrid devices available on the network, allowing you to
select/assign the devices you are using.
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12.

The Inventory and SoundGrid Servers Table

The Inventory table displays all SoundGrid devices available on the network, allowing you to
select and assign the devices you are using.
Inventory Fields
Assign selects devices for usage in your setup. The number you assign the device is its index
number in the Inventory list. For an I/O device, setting 1 means this is the first I/O device, and its
channels will be the first listed in the routing menus.
I/O: An I/O device that streams audio to and from the SoundGrid network. On your console the
DiGiCo I/O should be selected and used.
MR: MultiRack, SoundGrid’s audio processing device. MultiRack is the device which receives
audio for processing. MultiRack utilizes SoundGrid DSP Servers as its processing engines.
Device displays the type and description of the device. When hovering with a mouse over a
device row, the device’s software/firmware version is displayed as a tool-tip.
Chn displays the number of channels available on the device. I/O and MultiRack channels
cannot be set and are display-only.
Name: Double-click in this field to rename the device. We recommend leaving this field at its
default value.
MAC Address / Computer Name displays the device’s MAC address or computer name.
Status displays the device’s status in real-time.
Device Firmware supports an Update button for each I/O or server device. Click the button to
update the device’s firmware if incompatible with the MultiRack version you are using. The
Update process will display a progress bar and status messages. Follow the status messages
and instructions carefully. At the end of the process (in some cases requiring you to reboot the
device), click the window’s Refresh button.
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ID: Applicable for I/O-type devices only. Clicking this button will temporarily turn on the selected
I/O’s link and activity LEDs, while turning the LEDs of all other I/O devices off, to allow
identification of the device in the network.
The Servers table is very similar to the Inventory table and is used in the same way. This table
is separate from the I/O Device table, since servers don’t have channels and do not receive
audio connections. Set “1” for the server you intend to use as your main processing engine; set
“2” for the server you intend to use as a redundant server.

13.

Setting SoundGrid Connections

The SoundGrid Connections window allows you to create audio connections (routes) between
Source and Destination devices.

Open the SoundGrid Connections window by selecting SoundGrid Connections from the
Window menu.
Changes in the SoundGrid Connections window are allowed only in Setup mode. In Show
mode, the window opens as display-only and no changes are allowed.
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On your console, SoundGrid Connections are hard-set by default to be recalled correctly
from the channels.
If your connections have been changed, you can easily correct this by tapping the Load
Default, in the dialog prompting for Load Default Connections. Navigate to D:\Waves\Factory
Presets\Connections folder and choose the Connections file.

14.

Updating the Firmware of the Waves I/O
Please note: If updating from SoundGrid V1, please refer to the last chapter.



On the DiGiCo Master Screen, click or touch Waves tab to open MultiRack SoundGrid.



Click or touch Window button and choose SoundGrid Inventory.



In the Inventory window, hover the mouse above the I/O device. A pop-up message
should indicate FW Version.



In the Inventory window, click Update next to the devices requiring an update and follow
prompts to complete update. Reboot updated devices.



If upgrading an SD7, repeat the steps above on the second engine to upgrade second
I/O.

Now you are ready to update your Waves SoundGrid Server/s.
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15.

Updating the Firmware of Waves SoundGrid DSP Servers

On the main MultiRack menu, click or touch the Window button and choose Inventory.

In the Inventory Window, click the Update button next to SoundGrid Server/s, and follow
prompts to complete update. Reboot updated devices.

If there is more than one SoundGrid connected to the switch, either as redundant servers
or as part an SD7 system, they will all be detected and can all be upgraded from the
same Inventory Window.

The Upgrade procedure is now complete.

16.

Updating the Firmware of the Waves I/O Card from

SoundGrid V1 – 2.5 to V9

Using a computer with an internet connection, download v1-to-v9-io-updater.zip from
http://www.waves.com/downloads/digico#v8
The digico-firmware-updater_for_sdx-type contains two executable files, listed below. One is
for SD7 only; another is for all other SD consoles.
SD7: www.waves.com/1lib/downloads/v8/digico/digico-firmware-updater-for-sd7-only.zip
Other SD Consoles: www.waves.com/1lib/downloads/v8/digico/digico-firmware-updater-forsd8-type.zip
1. Run v1-to-v9-io-updater.zip. Choose your USB flash drive root folder as your
destination and Extract.
2. Plug the USB flash drive into a USB port on your console.
3. Right-click on the Start Menu button in the windows tool-bar, and choose Explore.
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4. Navigate to your USB flash drive and run the appropriate updater from your USB flash
drive.
5. The updater will scan the network and will find the I/O device/s. From the drop-down
menu, choose the I/O you would like to update.
6. Follow the status messages and instructions carefully to complete the update. At the end
of the process, reboot the console.
7. After reboot, touch the Waves tab to open MultiRack SoundGrid.
8. On the main MultiRack menu click or touch Window button and choose SoundGrid
Inventory.
9. In the SoundGrid Inventory window, hover above the I/O device; a pop up message
will indicate the firmware version. Click Update next to relevant devices and follow the
instructions.
10. If upgrading an SD7, repeat steps 4 – 9 above for the second engine.
The Upgrade procedure is now complete.

17.

Updating DiGiCo Console Software or Offline Editor After

Installing Waves V9
When updating the DiGiCo console software or offline editor after installing Waves V9, the
update might erase necessary Waves files. These files can be retrieved from the following
locations:


On DiGiCo Console
Go to D:\Waves\SoundGrid\SG_Digico apps folder,
Copy the content and paste/overwrite to: D:\SDx folder.



DiGiCo Offline Editor
Go to C:\Program Files(x86)\Waves\SoundGrid\SG_Digico apps backup folder,
Copy the content and paste/overwrite to: C:\SDx folder.
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